Vulnerabilità su Kernel Linux, chiusa da Canonical

Canonical ha annunciato un problema di protezione che è stato scoperto nel kernel di Linux che lede Ubuntu 12,04 LTS (Precise Pangolin) del sistema operativo.

Secondo Canonical, alcuni problemi sono stati corretti nel kernel di Linux.

Ad esempio, una corruzione dello stack Xen è stata riportata nel kernel di Linux. Un utente non privilegiato in un sistema  32bit pvops può causare il crash del sistema ospite o utilizzarlo in maniera non corretta.

La falla di sicurezza può essere risolta se si aggiorna il sistema per  linux-image-3.5.0-26-generic (3.5.0-26.42 ~ precise1).

Non dimenticare di riavviare il computer dopo l’aggiornamento!

ATTENZIONE: A causa di un cambiamento inevitabile ABI, i pacchetti del kernel hanno un nuovo numero di versione, che vi costringerà a reinstallare e ricompilare tutti i moduli di terze parti del kernel. Inoltre, se si utilizza il pacchetto linux-restricted è necessario aggiornarlo per ottenere i moduli che funzionano con la nuova versione del kernel Linux.

Avvia una discussione su questo tema per coinvolgere i lettori con le tue opinioni